Configurar RIPv2 en routers - Cisco Packet Tracer 2019

Hoy veremos como configurar RIPv2 en Routers Cisco, teniendo en cuenta que RIP es mejor usarlo cuando nuestra red es pequeña y posee pocos routers todo esto ya que va ligado a una velocidad de convergencia lenta y su métrica estructurada en la cantidad máxima de saltos que serían 15.

Así pues supongo que si estás aquí es porque eres estudiante y probablemente ves alguna materia directamente relacionada con esto, así que trataré de explicar cada detalle paso a paso pues soy consciente de que no todos saben lo mismo y algo por muy obvio que parezca alguno quizá no tenga idea de como hacerlo.

Configurando RIP en redes con 3 routers

Realmente el proceso es lo mismo, ajeno al número de routers que tengas 2,3,4 o 5 sólo debes ser ordenado y estructurar muy bien lo que haces para que te quede claro todo, en mi caso usaré la topología de la siguiente imagen, pueden descargar el archivo RIP2-SkullTrap en packet Tracer (uso la versión 7.1.1 que también la puedes descargar dando click aquí):
Topología que implementaremos con RIPv2
DIRECCIONAMIENTO IP

Es importante antes de empezar todo, saber que IPs asignaremos a cada interfaz y red (conexiones), tanto en el router R1 (Conexión A) como en R3 (Conexión D) serán máscara /24 y en R2 (Conexión B - C) toda interfaz que a él se conecte será máscara /30, entonces basado en lo anterior esta es la tabla con las redes e interfaces y sus respectivas IPs a configurar:

RED A
192.168.1.0/24
RED B
192.168.3.0/30
RED C
192.168.4.0/30
RED D
192.168.2.0/24
PC0

Fa0
IP: 192.168.1.2

Máscara: 255.255.255.0
Gateway: 192.168.1.1
R1

Se0/0/0
IP: 192.168.3.1

Máscara: 255.255.255.252
R2

Se0/0/1
IP: 192.168.4.1

Máscara: 255.255.255.252
R3

Gig0/0
IP: 192.168.2.1

Máscara: 255.255.252.0
R1

Gig0/0
IP: 192.168.1.1

Máscara: 255.255.255.0
R2

Se0/0/0
IP: 192.168.3.2

Máscara: 255.255.255.252
R3

Se0/0/0
IP: 192.168.4.2

Máscara: 255.255.255.252
PC1

Fa0
IP: 192.168.2.2

Máscara: 255.255.255.0
Gateway: 192.168.2.1
¿No entiendes la tabla? No te preocupes yo te la explico, como pudimos ver la imagen de la topología cada conexión tiene una letra en mayúscula y hace referencia a la red que hay de allí despliega el nombre del equipo y la respectiva IP de interfaz y máscara que le vamos a configurar.


ESTO ES LO QUE HAREMOS...

Entendida la tabla de direccionamiento anterior, configuraremos las interfaces de los routers con sus IPs asignadas. Luego, habilitaremos RIPv2 en cada router para que publique su tabla de enrutamiento, hecho esto podemos verificar las tablas de enrutamiento y hacer ping entre ambos computadores y así corroborar el buen funcionamiento de los routers y RIPv2


- Empezaremos configurando el Router R1 con parámetros elementales:

1. Abrimos el CLI de R1.

2. Accedemos al modo privilegiado.

R1>enable

3. Vamos al modo de configuración global.

R1#config t

4. Ahora vamos a configurar la interfaz (Gigabit 0/0)

R1(config)#interface gi0/0

5. Configuraremos la dirección IP respectiva de la tabla con su máscara, la encendemos y luego salimos de ese modo. 

R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

6. Entramos al modo de configuración de la interfaz (serial0/0/0)

R1(config)#interface serial0/0/0

7. Configuramos la respectiva dirección IP según la tabla, si descargaste el archivo packet tracer no es necesario asignar un clock rate pues este ya está asignado de forma automática, luego encendemos la interfaz y salimos.

R1(config-if)#ip add 192.168.3.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

8. Ahora sólo queda guardar nos devolvemos al modo privilegiado para hacerlo.

R1(config)#exit
R1#wr
Building configuration...[OK]
R1#

9. Listo, por ahora dejaremos aquí y luego configuraremos RIPv2



Ahora vamos a configurar R2, para ello.

1. Abrimos el CLI en R2.

2. Vamos al modo privilegiado y luego ingresamos al modo de configuración global.

R2>enable
R2#config t

3. Vamos a la configuración de la interfaz en este caso la (serial0/0/0) de R2 y luego asignamos su ip, máscara, la encendemos y luego salimos.

R2(config)#interface serial0/0/0
R2(config-if)#ip add 192.168.3.2 255.255.255.252
R2(config-if)#no shutdown 
R2(config-if)#exit

4. Ahora vamos a la siguiente interfaz de R2 faltante que sería la (serial0/0/1) luego asignamos su ip, máscara, la encendemos y salimos.

R2(config)#interface serial0/0/1
R2(config-if)#ip add 192.168.4.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit

5. Nos devolvemos al modo privilegiado y guardamos la configuración en R2.

R2(config)#exit
R2#wr
Building configuration...[OK]
R2#

6. De momento dejamos así R2 y luego configuraremos RIPv2.



Ahora vamos a R3 y hacemos el mismo proceso que en R1 y R2.

1. Abrimos el CLI del router R3.

2. Ingresamos al modo privilegiado y luego al modo de configuración global.

R3>enable
R3#config t

3. Luego a la configuración de la interfaz (serial0/0/0) y asignamos IP, máscara, la encendemos y salimos.

R3(config)#interface serial0/0/0
R3(config-if)#ip add 192.168.4.1 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit

4. Seguimos con la interfaz (Gigabit0/0) vamos a su configuración, asignamos IP, máscara, encendemos y salimos.

R3(config)#interface gi0/0
R3(config-if)#ip add 192.168.2.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit

5. Salimos del modo de configuración global y guardamos los cambios hechos en el equipo.

R3(config)#exit
R3#wr
Building configuration...[OK]
R3#

6. Listo no es más con la IP de cada interfaz en todos los routers, queda ir al siguiente paso.



CONFIGURANDO RIPv2...

Ahora sí, usaremos RIPv2 en nuestra topología. Es importante saber que cuando configuramos RIPv2 usamos el comando network a él debemos agregar la dirección IP de la red o conexión que queremos publicar si esta se encuentra directamente conectada al router. Entonces:


 - Configuramos primero R1:

1. Vamos al modo de configuración global y luego al modo de configuración del router con RIP.

R1#config t
R1(config)#router rip

2. Aplicamos al protocolo RIP la versión 2.

R1(config-router)# version 2

3. Publicamos las redes/conexiones vinculadas directamente a R1.

R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.3.0

4. Salimos del modo de configuración del Router y luego guardamos lo cambios en el equipo.

R1(config)#exit
R1#wr
Building configuration...[OK] 
R1#

5. Ya quedó.



Bien, seguiremos con R2 configurando RIP:

1. Ingresamos al modo configuración global, habilitamos la configuración RIP en el router y luego aplicamos la versión 2.

R2#config t
R2(config)#router rip
R2(config-router)#version 2

2. Publicamos la redes conectadas directamente a R2 que serían B - C según la tabla.

R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.4.0

3. Salimos de una vez hasta el modo de configuración y luego guardamos los cambios hechos.

R2(config)#end
R2#wr
Building configuration...[OK]
R2#

4. Listo.

Finalmente configuramos RIPv2 en el router R3.

1. vamos al modo configuración global, habilitamos la configuración RIP en el router y luego aplicamos la versión 2.

R3#config t
R3(config)#router rip
R3(config-router)#version 2

2. Publicamos la redes conectadas directamente a R2 que serían C - D según la tabla.

R3(config-router)#network 192.168.4.0
R3(config-router)#network 192.168.2.0

3. Salimos hasta el modo privilegiado y guardamos cambios hechos.

R3(config)#end
R3#wr
Building configuration...[OK]
R3#

4. Listo.
 

Hasta aquí, si hiciste los pasos uno a uno ya tienes RIPv2 configurado. Para probar si todo está correcto escribimos el comando show ip route para así ver la tabla de enrutamiento y observar las rutas aprendidas mediante RIP (Indicadas con una R) desde el router vecino. Debería salir algo así en las tablas de enrutamiento: 

R1:

192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, GigabitEthernet0/0
L 192.168.1.1/32 is directly connected, GigabitEthernet0/0
R 192.168.2.0/24 [120/2] via 192.168.3.2, 00:00:18, Serial0/0/0
192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.3.0/30 is directly connected, Serial0/0/0
L 192.168.3.1/32 is directly connected, Serial0/0/0
R 192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:18, Serial0/0/0

R2:

R 192.168.1.0/24 [120/1] via 192.168.3.1, 00:00:22, Serial0/0/0
R 192.168.2.0/24 [120/1] via 192.168.4.1, 00:00:04, Serial0/0/1
192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.3.0/30 is directly connected, Serial0/0/0
L 192.168.3.2/32 is directly connected, Serial0/0/0
192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.4.0/30 is directly connected, Serial0/0/1
L 192.168.4.2/32 is directly connected, Serial0/0/1

R3:

R 192.168.1.0/24 [120/2] via 192.168.4.2, 00:00:01, Serial0/0/0
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.2.0/24 is directly connected, GigabitEthernet0/0
L 192.168.2.1/32 is directly connected, GigabitEthernet0/0
R 192.168.3.0/24 [120/1] via 192.168.4.2, 00:00:01, Serial0/0/0
192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.4.0/30 is directly connected, Serial0/0/0
L 192.168.4.1/32 is directly connected, Serial0/0/0

Verificado lo anterior, vamos al último paso hacer un ping y así verificar que ambos computadores están OK en conexión. Para lo único que falta es asignar la IP, máscara y gateway a PC0 y PC1 quedando algó así:

Configuración para PC0:

Configuración para PC1:


Con los PC configurados haremos el ping desde el PC0 hacia el PC1 así:


PC0:\>ping 192.168.2.2

Pinging 192.168.2.2 with 32 bytes of data:

Reply from 192.168.2.2: bytes=32 time=3ms TTL=125
Reply from 192.168.2.2: bytes=32 time=4ms TTL=125
Reply from 192.168.2.2: bytes=32 time=2ms TTL=125
Reply from 192.168.2.2: bytes=32 time=5ms TTL=125

Ping statistics for 192.168.2.2:
   Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
   Minimum = 2ms, Maximum = 5ms, Average = 3ms

Y así culminamos esto, lo mejor detallado posible ha sido escrito, sin embargo si hay dudas más abajo está la caja de comentarios.

Hasta la próxima SkullTrapers ;)
Compartir:

8 webs Proxy gratis online para evitar bloqueos y ser anónimo 2019

Si en tu universidad, trabajo u otro lugar bloquean algunas webs, blogs o redes sociales probablemente este sea tu post, hoy te traigo una lista de proxies gratuitos para evitar restricciones y claro conservar tu privacidad y anonimato en dichos portales. Así para poder hacer uso de estos proxies no se necesita más que un navegador web para poder acceder desde allí. 

Es importante hacer mención que cada uno de los siguientes proxies poseen la misma funcionalidad, pero algunos tendrás cosas extras que otros no, como la posibilidad de escoger un país para conectarse y demás.

Aquí la lista de proxies gratuitos de momento: 

Para ir hacia algunos de los proxies da click sobre el nombre del mismo.

1. Navega sin Ley
Quizá el mejor de la lista, en español y fácil de entender, nada que decir y por eso en el puesto uno lo tenemos.

2. Dont Filter
Te dará acceso a cualquier sitio web, con sus distintas funciones de desbloqueo web además de darte anonimato ideal para usarlo desde universidades.

3. BlewPass
Este es interesante nos deja conectar desde al menos 10 países como servidor y algunas ciudades en específico como IP de localización, todo lo demás similar a cualquiera de los otros proxies aquí mencionados.

4. Hide me
Da las opciones de escoger entre tres países de momento para podernos conectar entre ellos: Alemania, Holanda y Estados Unidos, además cuenta con extensión para chrome y Firefox.

5. Proxify
Diseñado para apuntar todos los formularios, imágenes, y enlaces a el mismo proxy, dando la seguridad de protección sí o sí.

6. New IP Now
Te da datos de la IP actual y las posibles que obtendrías al navegar usando dicho proxy es bastante dinámico y su velocidad es buena.

7. Proxy Hidester
Con una interfaz limpia bien diseñada y en español se auto titula como el proxy más rápido del mundo dándote a escoger el tipo de servidor que quieres usar para conectarte.

8. WinCrypto Free
Dinámico y rápido, con diferntes filtros pque podrán ser usados según el sitio web que desees ver y claro conservando tu privacidad y anonimato en la navegación.


Son todos los proxies de momento, es probable que no todos te funcionen es de recordar que esto va en función del tipo de red y fuerza de la restricción que coloque tu empresa o universidad. ¿Tienes algún proxy que te funcione? no dudes en compartirlo para actualizar la lista en este post.

Es todo SkullTrapers ;)

Compartir:

Descargar Wifislax 2.0 ISO última versión estable 2019 - LiveUSB

Ahora aquí podrás descargar la última versión de wifislax se trata de la V2.0, lanzada el día 27 de febrero en el foro oficial de Seguridad Wireless donde participan muchos usuarios con dudas y aportes por Wifislax en casi  todas sus versiones. 


 
¿Que cambios hay en esta versión?

Comparado con la versión V1.1 que la pueden descargar aquí por cierto, tenemos algunas diferencias en el sistema operativo Wifislax que apriori no son muchos pero si de gran impacto. 

El cambio más notable podría ser la actualización finalmente a la herramienta de la suite de aircrack-ng usada para montar los dispositivo en modo monitor.

Desde hace ya tres años , las versiones de airmon-ng a partir de la 1.4 , ya no generan interfaces virtuales de tipo monX , si no que destruyen la interface y generan una nueva para el modo monitor del tipo  wlanXmon , ese cambio generaba que TODOS , los automatimos (scripts) que en ese momento tenia wifislax fallarán ,al variar dicho compartamiendo airmon-ng.

Se han adaptado bastantes de esos scripts para poder dar finalmente el salto , esto disgustara a muchos , puesto que hasta la fecha , no hay versiones compatibles de utilidades como linset o derivados.

No obstante , en la iso , se mantiene una version vieja de airmon-ng , llamada "airmon-ng-old"  , de manera que algunos scripts podrían funcionar simplemente cambiando las llamadas a airmon-ng por airmon-ng-old.

Otro cambio significativo fue desechar la version 1.4 de reaver , y empezar a usar la versión en curso adoptada por todas las distros (1.6.x) , las pruebas que realicé arrojaron mejores resultados funcionando con todo lo nuevo , que en el mismo escenario usando las viejas herramientas. El sistema soporta de serie multilib , para un correcto funcionamiento de wine.

Las tarjetas graficas AMD/RADEON , quedan finalmente sin soporte , ya que desde hace un par de años, AMD , decidio distribuir su driver en forma de "binario" , y no de "instalable" , como era antes, eso hace que ponerlo a funcionar en algunas distros, sea toda una odisea.

Se ha mirado tambien de aligerar la iso un poco, dejando atrás librerías que de serie no eran necesarias.


Descargar Wifislax 2.0 ISO 2019

Para descargar el SO escoge el servidor de descarga que más te guste:


Por supuesto todos los créditos de la publicación de este versión a "USUARIONUEVO" en el foro de seguridad Wireless, por otra parte dejo el driver NVIDIA para hashcat, click aquí.

Es todo de momento, si hay alguna duda o sugerencia no olvides mencionarla en comentarios. Hasta la próxima SkulTrapers ;)
Compartir:

Descargar CADe SIMU 3.0 + PC SIMU 2.0 con clave - 2019

No hace mucho que empecé una nueva materia en mi Universidad se trata de PLC y me pareció interesante este Software bastante simple de tener y trabajar se trata de CADe SIMU que incluye el PC SIMU, el primero en su versión 3.0 y el segundo en su versión 2.0 creo que no hace falta entrar en detalles o despacharme la descripción de los programas después de todo si estás aquí es porque sabes para que sirven y aprenderás a usarlos.


Descargar CADe SIMU y PC simu

1. El primer paso será obtener el link de descarga que está aquí abajo:


2. Cuando descarguemos el archivo .rar, lo siguiente será abrirlo y veremos los siguientes archivos chuleados en la imagen:
 


3. Lo recomendable es que extraigas cada .rar de cada programa en una nueva carpeta puede ser en escritorio u otro lugar de tu preferencia, si abrimos por ejemplo "CADe_SIMU_V3" veremos los siguientes archivos ya extraídos en una carpeta:


El archivo señalado es el que abrirá el programa.


4. Una vez abierto, el programa cargará y nos pedirá una clave inicial las cuales serán:


Para CADe Simu - 4962
Para PC simu - 9966


5. Ingresada la clave el programa cargará y funcionará correctamente:


6. Con esto quedará listo el programa para usarlo sin problema alguno.


Nota: Para PC Simu es el mismo procedimiento a partir del paso 𝟐.


Es todo por el momento 😎.
Compartir:

Cisco Packet Tracer ventana CLI y physical no aparecen en router - switch

Un problema común en Cisco Packet Tracer es que al abrir la configuración de nuestro Switch o Router no salgan las pestañas de CLI y physical o física, aquí les traeré en algunos cortos pasos la solución a este problema, no hace falta reinstalar el programa o reiniciar el equipo (Soluciones descabelladas que encontré en foros).

Sólo podemos ver la ventana Config y Attributes


 SOLUCIÓN PASO A PASO....

1. Para tener todas las ventanas activas vamos a Cisco Packet Tracer en la pestaña Options > Preferences:



2. En la subpestaña "Hide" vamos a desmarcar las opciones:

- Hide physical tab
- Hide all devices CLI tab
- Hide Router/switch CLI tab 

Desmarca las opciones resaltadas en amarillo



3. Y listo vuelve al router o switch a verificar que tel salgan todas las opciones para su configuración veamos:




Con esto el problema está solucionado tendremos todas las opciones activas en nuestro cisco packet Tracer sin importar la versión, ¿Alguna duda? comenta.

Gracias por leer...
Compartir:

PROYECTO: Alarma de carro en C++ con Fredoom mbed KL25Z código

Este proyecto está desarrollado en C++ al final del post podrás descargar el código + archivos de montaje, proteus y código.
Hace muchos meses que no traía un proyecto nuevo, las ocupaciones y tanto trabajo no liberan mucho espacio, sin embargo hoy traigo un diseño breve de una alarma digamos que implementada para carro, pero el proyecto lo puedes modificar a conveniencia, claro desarrollado en la tarjeta Freedom de Freescale o actualmente de NXP cuya referencia es la KL25Z.


Te dejo un vídeo del proyecto funcionando


Características del proyecto...

Se diseñará un sistema básico de alarma para automóvil. Dicho sistema debe contar con lo siguiente: 

- 5 pulsadores que simulen las 5 puertas (programados por interrupción) 
- 1 Pulsador que simule la activación o desactivación de la alarma 
- 1 pulsador que simule el On/Off del vehículo.  
- 1 Led Rojo para simular la sirena 
- 1 Led Verde para simular la bomba de combustible  
- 1 Pulsador de pánico (Interrupción) 

¡Así debe funcionar! El pulsador de activación de alarma habilita o deshabilita el sistema de seguridad. Si el sistema está activado, se genera un escaneo de todos los pulsadores del sistema. Si algún pulsador se activa, la alarma debe activar de manera intermitente el LED que simula la sirena y apagar el LED de la bomba de combustible. Por otra parte, si el usuario presiona el botón de pánico, el sistema de alarma debe hacer lo siguiente: Esperar un tiempo de 1 minuto Activar la sirena de manera intermitente  Apagar el led que simula la Bomba de combustible con el fin de parar el motor  Solo el usuario puede reactivar el sistema mediante el uso del pulsador de activación/ desactivación de la alarma.

DESARROLLO COMPLETO DEL PROYECTO 
Como siempre doy una breve aclaración este proyecto está diseñado exclusivamente para la tarjeta ya mencionada de Freedoom, pero, si dominas el código muy bien es probable quelo puedas adaptar o entender su lógica de programación y usarlo en otra tarjeta ya que en esencia es fácil de hacer.

1. Materiales y componentes

Aquí dejaremos la lista de componentes que hemos usado para el desarrollo de este proyecto:

- x1 Tarjeta Freedoom NXP KL25Z con su cable USB
- x8 Pulsadores normalmente abiertos pequeños
- x2 Resistencias de 220 Ohms (Rojo, Rojo, Café)
- x2 leds rojo y verde cada uno.
- x1 Buzzer de 5V.
- Cables jumpers para crear conexiones.
- x1 Protoboard

¡Listo! Con esto podrás empezar a hacer todo el montaje. 


2. Montaje en la Protoboard - Simulación

Usé proteus para hacer un esquemático muy fácil de entender pero como tal no es posible simular el funcionamiento del circuito ya que no existen librerías de Freedoom para proteus sin embargo puedes checar los pines y conexiones de cada elemento:

Esquemático circuito a pines de la tarjeta
Recordemos que los pines que se ven en el esquema anterior es donde se deben conectar en la tarjeta para ello debes mirar el esquemática de conexiones de pines de la tarjeta y listo. (Recuerda que al final del post podrás descargar todos los archivos proteus + código + montaje).


3. Código proyecto

En este proyecto no se requiere ningún tipo de librerías externas lo puedes usar de forma directa y sin problema alguno:
/*SISTEMA DE ALARMA PARA CARRO CON DETECCIÓN EN 5 PUERTAS V1.0

DESARROLLADOR: Andrés Felipe Lozano
                                      */

#include "mbed.h"

Timeout crono;  //Variable encargada de activarse después de X tiempo

//SALIDAS PINES
DigitalOut verde(PTC7,1);  //LED INDICADOR VERDE
DigitalOut buzzer(PTC0,1); //PIN DONDE DEBE IR EL BUZZER

//ENTRADAS PINES
InterruptIn sw1(PTA13); //Puerta uno
InterruptIn sw2(PTD5); //Puerta dos
InterruptIn sw3(PTD0); //Puerta tres
InterruptIn sw4(PTD2); //Puerta cuatro
InterruptIn sw5(PTD3); //Puerta cinco
InterruptIn onoffcar(PTD1); //Botón ON/OFF del auto
InterruptIn panico(PTA1); //Botón depánico
InterruptIn StarStop(PTA2); //Star/Stop

//VARIABLES BOOLEANAS
bool star=true;
bool aux1,aux2, aux3;

/* INICIO DECLARACIÓN DE MIS FUNCIONES */

void onoffalarma(){
     star=!star;
     wait(1); //Elimina rebotes en el botón
    }

void puertas(){                            //Proceso que se ejecutará al llamar la función puertas
  while(1){
  buzzer = 1;
  verde=0;
    wait(0.05);
    buzzer = 0;
    wait(0.05);
    aux1 = StarStop.read(); 
    if (aux1 == 0){
        NVIC_SystemReset ();    //Parámetro reservado de mbed para reiniciar mi tarjeta 
    }   
  }
 }
 
 void carro(){ //FUNCIÓN ENCENDIDO CARRO
 verde = !verde;
 wait(1);
       if(sw1==0){ 
          buzzer=0;
       }
}
 
 void SOS(){ //FUNCIÓN BOTÓN PÁNICO
     while(1){
          buzzer = 1;
          verde=0;
          wait(0.05);
          buzzer = 0;
          wait(0.05);
          aux1 = StarStop.read(); 
               if (aux1 == 0){
                   NVIC_SystemReset ();
               }   
     }
}
/*FIN DECLARACIÓN DE MIS FUNCIONES */

int main() {
    StarStop.fall(&onoffalarma);
    buzzer=0;
    verde=0;  
    onoffcar.rise(&carro);
                                   
while(1){
                  
          if(star){
             buzzer=0; 
          }
          else{ }
         
          if(verde==1){ //Si el led verde está encendido entonces anulará la ejecución de activar la alarma así opriman las puertas
                      sw1.fall(NULL); //Flancos de bajada 
                      sw2.fall(NULL); 
                      sw3.fall(NULL);
                      sw4.fall(NULL);
                      sw5.fall(NULL);
                   } 
                   else{ 
                       sw1.fall(&puertas);
                       sw2.fall(&puertas);
                       sw3.fall(&puertas);
                       sw4.fall(&puertas);
                       sw5.fall(&puertas); 
                       }
 
              
          if(verde==1){ //Si el led verde está encendido entonces ejecutará lo siguiente
                   if(panico==0){              //Si se pulsa el botón de pánico ejecutará la acción del TIMEOUT que llama la función SOS    
                      crono.attach(&SOS, 10.0); //Ejecuta después de 10 segundos 
                   }
          }          
          
}
}


4. Montaje final del Proyecto

Realmente este paso no tiene ningún criterio analítico pero muchos en el desarrollo de sus proyectos tienen dudas de este montaje como queda realmente así que aquí les dejo una fotografía:

Montaje físico circuito + tarjeta
Finalmente es todo lo que hay referente a este proyecto más claro no puede ser a continuación podrás descargar el proyecto completo este incluye código listo para copiar + archivo de proteus (Recuerda que no es simulación y solo esquemático de pines y circuito, pero sirve) + guía de ayuda + Fotos del montaje en buena resolución:

https://drive.google.com/open?id=1pk7rG9kWk6LxXzeGRS3qtLL8vrqHdYId

Es todo en este post, espero les sea de utilidad y aumenten su dominio en estos temas, ya que no se trata de sólo copiar. Hasta la próxima ;)
Compartir:

Descargar Amplificadores Operacionales 5ta Edición Coughlin

¡Hey SkullTraper! Un breve post para compartir un libro que he usado hace un tiempo para aprender sobre amplificadores Operacionales se trata de "Amplificadores Operacionales y Circuitos integrados Lineales" cuyo autor es Robert F. Coughlin y en su quinta edición


No hace falta aclarar mayor cosa referente al libro recordemos que es interesante para aprender todo el tema relaciona con la introducción a los amplificadores Operacionales :) 

Descarga el libro click aquí  

Nos vemos en un próximo post ;)hasta la próxima.
Compartir:

SkullTrapers

 

CLICK AQUI PARA IR A NUESTRA TIENDA ON LINE ARDUINO, ELECTRÓNICA, COMPONENTES